EIGRP PASSIVE INTERFACE

Secara default network interface yang di advertise ke EIGRP adalah dalam kondisi aktif, jadi router akan otomatis melakukan adjancecy dengan tetangga yang melakukan advertise network EIGRP dengan AS yang sama. Hal ini mungkin akan memeberi kemudahan bagi network Adminstrator, namun kadang peristiwa ini menjadi tidak aman karena khawatir ada router yang tidak dikenal melakukan adjancecy yang tidak aman.
Contoh scenarionya adalah seperti berikut :
Semula ada topologi jaringan seperti gambar diatas semua router diadvertise ke network EIGRP dengan AS 10.  Konfigurasi untuk masing-masing router adalah seperti beriktu.
R1
interface FastEthernet0/0
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.2.1 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 10
 network 10.0.0.0
 no auto-summary
R2
interface FastEthernet0/0
 ip address 10.0.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.1.1 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 10
 network 10.0.0.0
 no auto-summary
R3
interface FastEthernet0/0
 ip address 10.0.1.2 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 10
 network 10.0.0.0
 no auto-summary
Khusus pada R1 coba kita cek interface yang ter-advertise ke routing EIGRP dengan perintah show ip eigrp interface.

R1#show ip eigrp interface

IP-EIGRP interfaces for process 10

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0              1        0/0        24       0/2           50           0
Fa0/1              0        0/0         0       0/1            0           0

Menurut informasi diatas untuk interface Fa0/1 yang menuju ke jaringan LAN ternyata masuk ke zona EIGRP. Alih-alih ada seorang user yang nekad jail mengganti salah satu komputer pada LAN dengan sebuah router cisco.

Pertama user jail tadi melakukan snifing ke R1 sehingga dia mendapatkan informasi bahwa network tersebut menggunakan routing protocol EIGRP dengan AS 10. Dengan begitu dia akan mengkonfigurasi router jail seperti berikut.
Jail
interface FastEthernet0/0
 ip address 10.0.2.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 10
 network 10.0.0.0
 auto-summary
Dengan begitu akan terjadi kondisi adjancecy dengan router jail.
*Mar  1 00:13:32.019: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 10.0.2.1 (FastEthernet0/0) is up: new adjacenced
Setelah itu user jail dapat melakukan apa saja yang tujuanya adalah merusak informasi routing yang telah terbentuk.
Solusi
Solusi yang paling efektif dan efisien adalah dengan sebuah command sederhana, yaitu command yang menjadikan interface router EIGRP disebut sebagai “passive interface”. 

R1(config)#router eigrp 10
R1(config-router)#passive-interface fastethernet 0/1
Passive interface adalah kondisi dimana interface router tidak akan mengirim dan menerima Hello Packet yang biasa dikirimkan oleh router EIGRP pada umumnya. Dengan begitu interface Fa0/1 pada R1 yang menuju ke LAN dijadikan sebagai passive interface agar informasi routing EIGRP tidak akan diteruskan dari interface tersebut.

EIGRP Timers

Agar komunikasi antar router EIGRP bisa terjaga routing protocol ini menggunakan 2 jenis Timers yaitu Hello Timer dan Hold Down Timer. Hello Timer adalah interval waktu yang digunakan untuk memastikan bahwa neighbor router masih aktif, sedangkan Hold Down Timer adalah apabila neighbor router tidak merespon maka dalam jangka waktu tertentu neighbor router tersebut akan masih dinyatakan aktif sebelum benar-benar dinyatakan mati. Secara default untuk koneksi High Speed Hello Timer EIGRP adalah 5 detik sedangkan untuk Hold Down Timer 15 detik. Dan untuk koneksi Low Speed Hello Timer di set 60 detik sedangkan Hold Down Timer 180 detik. Untuk ilustrasi EIGRP Timer adalah seperti gambar dibawah ini.
Untuk masalah EIGRP Timer sendiri kita dapat mengatur sendiri sesuai keinginan, menurut teori yang ada router yang saling berinteraksi harus memiliki EIGRP Timer yang sama karena bila tidak akan timbul miss komunikasi, namun setelah ane labkan secara praktek hal itu tidak mempengaruhi apapun, itu pendapat ane. :p
Untuk mengganti EIGRP Timer dapat kita gunakan perintah ip hello-interval eigrp (as) (time second) dan ip hold-time eigro (as) (time second)

Sesuai gambar topologi diatas konfigurasi masing-masing router untuk advertise ke EIGRP.

R1

Building configuration…

Current configuration : 814 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive   
 log config
  hidekeys
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.0.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.1.1 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 10
 network 10.0.0.0 0.0.0.255
 network 10.0.1.0 0.0.0.255
 auto-summary
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!         
!
line con 0
line aux 0
line vty 0 4
!
!
end

R2

Building configuration…

Current configuration : 718 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive   
 log config
  hidekeys
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.0.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 10
 network 10.0.1.0 0.0.0.255
 auto-summary
!         
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
R3

Building configuration…

Current configuration : 718 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive   
 log config
  hidekeys
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 10
 network 10.0.0.0 0.0.0.255
 auto-summary
!         
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Lakukan perubahan EIGRP timer pada R1 menuju R3 dengan hello timer 60 detik dan Hold Down Timer 180.
R1(config)#interface fastethernet 0/0
R1(config-if)#ip hello-interval eigrp 10 60
R1(config-if)#ip hold-time eigrp 10 180
Lakukan verifikasi dengan perintah show ip eigro neighbor pada R3.

R3#show ip eigrp neighbors 
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.0.0.2                Fa0/0            170 01:36:27 1266  5000  0  9

MODUL MIKROTIK FUNDAMENTAL

Alhamdulillah selesai juga coretan ane tentang konfigurasi Mikrotik level fondumental karena pembahasannya lumayan banyak ane jadikan satu file aja, walaupun corentan ane masih jauh dari sempurna semoga bisa bantu agan yang pengen belajar Mikrotik dari basic.
langsung aja bisa didownload di link ini

EIGRP STUB AREA

EIGRP Stub Area adalah keadaan dimana sebuah router yang terlibat pada jaringan EIGRP terletak di ujung, seperti pada topologi jaringan dibawah ini.

Hal yang menonjol pada pembahasan kali ini adalah pada router R4 dan R5 dapat diilustrasikan dengan gambar dibawah ini.

Bila dilihat dari ilustrasi diatas sebenarnya R5 hanya memberi informasi routing yang sama saja seperti R4 berikan ke R5. Karena kondisi ini posisi R5 menjadi Stub (pojok) dan untuk mengefektifkan jaringan sekiranya R5 hanya menerima informasi saja tanpa harus mengirimkan informasi routing ke tetangganya. Ini dinamakan EIGRP stub. Konfigurasi Lab pada topologi diatas adalah seperti berikut.
R1

R1#show run 
Building configuration…

Current configuration : 850 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive   
 log config
  hidekeys
!
!
!
!
!
!
interface Loopback0
 ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.6 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.0.9 255.255.255.252
 duplex auto
 speed auto
!
router eigrp 10
 network 10.0.0.4 0.0.0.3
 network 10.0.0.8 0.0.0.3
 network 11.11.11.11 0.0.0.0
 no auto-summary
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!         
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

R1#
R2

Building configuration…

Current configuration : 850 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive   
 log config
  hidekeys
!
!
!
!
!
!
interface Loopback0
 ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.0.5 255.255.255.252
 duplex auto
 speed auto
!
router eigrp 10
 network 10.0.0.0 0.0.0.3
 network 10.0.0.4 0.0.0.3
 network 22.22.22.22 0.0.0.0
 no auto-summary
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!         
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

R2#    
R3

Building configuration…

Current configuration : 853 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive   
 log config
  hidekeys
!
!
!
!
!
!
interface Loopback0
 ip address 33.33.33.33 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.10 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.0.14 255.255.255.252
 duplex auto
 speed auto
!
router eigrp 10
 network 10.0.0.8 0.0.0.3
 network 10.0.0.12 0.0.0.3
 network 33.33.33.33 0.0.0.0
 no auto-summary
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!         
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

R3# 
R4

Building configuration…

Current configuration : 974 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive   
 log config
  hidekeys
!
!
!
!
!
!
interface Loopback0
 ip address 44.44.44.44 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.0.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.0.0.13 255.255.255.252
 duplex auto
 speed auto
!
router eigrp 10
 network 10.0.0.0 0.0.0.3
 network 10.0.0.12 0.0.0.3
 network 44.44.44.44 0.0.0.0
 network 192.168.1.0 0.0.0.3
 no auto-summary
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!         
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

R4#
R5

Building configuration…

Current configuration : 855 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive   
 log config
  hidekeys
!
!
!
!
!
!
interface Loopback0
 ip address 55.55.55.55 255.255.255.255
!
interface FastEthernet0/0
 ip address 172.16.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.2 255.255.255.252
 duplex auto
 speed auto
!
router eigrp 10
 redistribute connected
 network 55.55.55.55 0.0.0.0
 network 192.168.1.0 0.0.0.3
 no auto-summary
 eigrp stub receive-only
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!         
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

R5#          

Untuk menjadikan posisi R5 menjadi Stub lakukan perintah berikut agar router R5 hanya menerima informasi routing saja tanpa melakukan pengiriman informasi routing kembali. adalah dengan perintah eigrp stub receive-only

R5

R5#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R5(config)#router eigrp 10
R5(config-router)#eigrp stub receive-only
R5(config-router)#end
Verifkasi hasil routing pada R4 dengan perintah show ip eigrp neighbor detail dan show ip route.

R4

R4#show ip eigrp neighbors detail 
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
2   192.168.1.2             Fa0/0             13 00:01:47   32   200  0  36
   Version 12.4/1.2, Retrans: 0, Retries: 0
   Receive-Only Peer Advertising ( No ) Routes
   Suppressing queries
1   10.0.0.1                Fa0/1             13 01:16:14   17   200  0  84
   Restart time 01:14:57
   Version 12.4/1.2, Retrans: 1, Retries: 0, Prefixes: 4
0   10.0.0.14               Fa1/0             11 01:16:22   19   200  0  82
   Restart time 01:14:28
   Version 12.4/1.2, Retrans: 2, Retries: 0, Prefixes: 4
R4#
R4#show ip route 
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area 
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     33.0.0.0/32 is subnetted, 1 subnets
D       33.33.33.33 [90/156160] via 10.0.0.14, 01:16:07, FastEthernet1/0
     22.0.0.0/32 is subnetted, 1 subnets
D       22.22.22.22 [90/409600] via 10.0.0.1, 01:16:35, FastEthernet0/1
     10.0.0.0/30 is subnetted, 4 subnets
D       10.0.0.8 [90/284160] via 10.0.0.14, 01:17:47, FastEthernet1/0
C       10.0.0.12 is directly connected, FastEthernet1/0
C       10.0.0.0 is directly connected, FastEthernet0/1
D       10.0.0.4 [90/307200] via 10.0.0.1, 01:17:47, FastEthernet0/1
     11.0.0.0/32 is subnetted, 1 subnets
D       11.11.11.11 [90/412160] via 10.0.0.14, 01:16:21, FastEthernet1/0
     192.168.1.0/30 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, FastEthernet0/0
     44.0.0.0/32 is subnetted, 1 subnets
C       44.44.44.44 is directly connected, Loopback0
R4#
Dari informasi diatas terlihat bahwa R4 tidak menerima informasi route redistribute connected yaitu network 172.16.0.0/24 karena R5 diset hanya untuk menerima informasi, namun bagaimana jika kita ubah type stub pada R5 menjadi EIGRP stub connected.

R5

R5#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
R5(config)#router eigrp 10
R5(config-router)#eigrp stub connected
R5(config-router)#end
R5#
Coba kita verifikasi kembali pada informasi routing di R4.

R4#show ip route 
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area 
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     33.0.0.0/32 is subnetted, 1 subnets
D       33.33.33.33 [90/156160] via 10.0.0.14, 01:20:07, FastEthernet1/0
     55.0.0.0/32 is subnetted, 1 subnets
D       55.55.55.55 [90/409600] via 192.168.1.2, 00:01:00, FastEthernet0/0
     172.16.0.0/24 is subnetted, 1 subnets
D EX    172.16.0.0 [170/307200] via 192.168.1.2, 00:01:00, FastEthernet0/0
     22.0.0.0/32 is subnetted, 1 subnets
D       22.22.22.22 [90/409600] via 10.0.0.1, 01:20:35, FastEthernet0/1
     10.0.0.0/30 is subnetted, 4 subnets
D       10.0.0.8 [90/284160] via 10.0.0.14, 01:21:48, FastEthernet1/0
C       10.0.0.12 is directly connected, FastEthernet1/0
C       10.0.0.0 is directly connected, FastEthernet0/1
D       10.0.0.4 [90/307200] via 10.0.0.1, 01:21:48, FastEthernet0/1
     11.0.0.0/32 is subnetted, 1 subnets
D       11.11.11.11 [90/412160] via 10.0.0.14, 01:20:22, FastEthernet1/0
     192.168.1.0/30 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, FastEthernet0/0
     44.0.0.0/32 is subnetted, 1 subnets
C       44.44.44.44 is directly connected, Loopback0
R4#
Dari informasi routing diatas terlihat walaupun R5 diset sebagai router stub namun dengan pengecualian R5 akan masih tetap mengirimkan informasi redistribute connected ke router tetangganya.

Sekian walaupun ngantuk-ngantukan belajar tetap semangat 🙂

EIGRP STATIC NEIGHBOR & SPLIT HORIZON

Assalamu’alaikumwarrohamtullahiwabarokatuh. Alhamdulillah sampai sekarang masih diberi kesehatan oleh sang kuasa sehingga saya masih bisa meneruskan coretan saya dan sedikit berbagi ilmu.hehe.. Sebelumnya telah dibahas mengenai bab EIGRP dengan materi basic EIGRP, sekarang dilanjut masih dengan tema yang sama yaitu EIGRP dengan materi Static Neighbor & Split Horizon. Kenapa kita pakai static neighbor padahal secara otomatis EIGRP akan mengenali tetangganya? teknik ini biasanya digunakan untuk jaringan yang tidak mengijinkan koneksi broadcast (dimana secara otomatis informasi routing protocol bisa saling bertukar informasi) seperti pada jaringan ISP. Sehingga kita harus secara manual memperkenalkan router yang saling terhubung menggunakan EIGRP. Untuk topologinya adalah seperti berikut :
Untuk mengawali Lab ini sebelumnya konfigurasi pada masing-masing router sebagai berikut.
R1
Building configuration…

Current configuration : 1117 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
multilink bundle-name authenticated
!         
!         
archive   
 log config
  hidekeys
!         
!         
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!         
interface FastEthernet0/0
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
interface Serial0/0
 ip address 10.0.0.1 255.255.255.248
 encapsulation frame-relay
 clock rate 2000000
 frame-relay map ip 10.0.0.3 153
 frame-relay map ip 10.0.0.2 152
!         
interface FastEthernet0/1
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
interface Serial0/1
 no ip address
 shutdown 
 clock rate 2000000
!         
router eigrp 10
 network 1.1.1.1 0.0.0.0
 network 10.0.0.1 0.0.0.0
 no auto-summary
!         
!         
ip http server
no ip http secure-server
!         
!         
control-plane
!         
!         
line con 0
line aux 0
line vty 0 4
!         
!         
end 
R2

Building configuration…

Current configuration : 1096 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
multilink bundle-name authenticated
!         
!
archive   
 log config
  hidekeys
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.0.0.9 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.0.0.2 255.255.255.248
 encapsulation frame-relay
 clock rate 2000000
 frame-relay map ip 10.0.0.3 251
 frame-relay map ip 10.0.0.1 251
!         
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router eigrp 10
 network 2.2.2.2 0.0.0.0
 network 10.0.0.2 0.0.0.0
 network 10.0.0.8 0.0.0.3
 no auto-summary
!
!
ip http server
no ip http secure-server
!         
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
!
!
end    
R3

Building configuration…

Current configuration : 1100 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
multilink bundle-name authenticated
!         
!
archive   
 log config
  hidekeys
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.14 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.0.0.3 255.255.255.248
 encapsulation frame-relay
 clock rate 2000000
 frame-relay map ip 10.0.0.2 351
 frame-relay map ip 10.0.0.1 351
!         
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router eigrp 10
 network 3.3.3.3 0.0.0.0
 network 10.0.0.3 0.0.0.0
 network 10.0.0.12 0.0.0.3
 no auto-summary
!
!
ip http server
no ip http secure-server
!         
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
!
!
end    
R4

Building configuration…

Current configuration : 820 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
multilink bundle-name authenticated
!         
!
archive   
 log config
  hidekeys
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.10 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.0.13 255.255.255.252
 duplex auto
 speed auto
!
router eigrp 10
 network 10.0.0.8 0.0.0.3
 network 10.0.0.12 0.0.0.3
 no auto-summary
!
!
ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
Karena pada konfigurasi maping frame relay tidak menggunakan broadcast sehingga pertukaran informasi routing tidak bisa berjalan, untuk mengeceknya lihat informasi routing dengan perintag show ip route.

R1
R1#show ip route 
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area 
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     10.0.0.0/29 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, Serial0/0
Dengan begitu kita harus secara manual memperkenalkan para tetangga router EIGRP, dengan perintah neighbor (ip address) (interface to neighbor).

R1

R1(config)#router eigrp 10
R1(config-router)#neighbor 10.0.0.2 serial 0/0
R1(config-router)#neighbor 10.0.0.3 serial 0/0
R1(config-router)#end
R1#
R2

R2(config)#router eigrp 10
R2(config-router)#neighbor 10.0.0.1 serial 0/0
R2(config-router)#end
R2#
R3

R3(config)#router eigrp 10
R3(config-router)#neighbor 10.0.0.1 serial 0/0
R3(config-router)#end
R3#
Kita verifikasi hasil konfigurasi diatas dengan melihat informasi routing kembali.
R1#show ip route 
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area 
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/2349056] via 10.0.0.3, 00:08:37, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/2297856] via 10.0.0.3, 00:04:18, Serial0/0
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/2323456] via 10.0.0.3, 00:01:33, Serial0/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D       10.0.0.8/30 [90/2221056] via 10.0.0.3, 00:08:58, Serial0/0
D       10.0.0.12/30 [90/2195456] via 10.0.0.3, 00:08:59, Serial0/0
C       10.0.0.0/29 is directly connected, Serial0/0
Dari informasi routing diatas ditemukan bahwa seharusnya untuk menuju ke IP 2.2.2.2 melalui 10.0.0.2 dan untuk menuju IP 4.4.4.4 seharusnya ada dua jalur yaitu via 10.0.0.2 dan 10.0.0.3.
R1#show ip eigrp neighbors 
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.0.0.3                Se0/0            157 00:03:05   10   200  0  11
R1#
Ternyata jalur frame relay yang menuju ke R2 tidak terbaca oleh EIGRP, ini dikarenakan fitur Split Horizon yang secara otomatis aktif. Split Horizon dipakai untuk mencegah looping routing, prinsipnya sederhana jika node A menyampaikan datagram ke tujuan X melalui node B, maka bagi B tidak masuk akal untuk mencapai tujuan X melalui A. Jadi, A tidak perlu memberitahu B bahwa X dapat dicapai B melalui A. Atau satu interface pada router tidak bisa berkomunikasi dengan lebih dari satu neighbor seperti pada jarigan frame relay. Maka dari itu fitur Split Horizon harus dimatikan dengan perintah berikut.
R1(config)#interface serial 0/0
R1(config-if)#no ip split-horizon eigrp 10
R1(config-if)#end

Verifikasi konfigurasi dengan perintah show ip route dan show ip eigrp neighbor.

R1# 
R1#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area 
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/2297856] via 10.0.0.2, 00:13:25, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/2297856] via 10.0.0.3, 00:13:25, Serial0/0
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/2323456] via 10.0.0.3, 00:13:25, Serial0/0
                [90/2323456] via 10.0.0.2, 00:13:25, Serial0/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D       10.0.0.8/30 [90/2195456] via 10.0.0.2, 00:13:26, Serial0/0
D       10.0.0.12/30 [90/2195456] via 10.0.0.3, 00:13:26, Serial0/0
C       10.0.0.0/29 is directly connected, Serial0/0
R1#
R1#show ip eigrp neighbors 
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   10.0.0.2                Se0/0            167 00:13:54  818  4908  0  12
0   10.0.0.3                Se0/0            171 00:14:53   12   200  0  12
R1#
Oke, selamat mencoba 🙂

SIMULATOR SWITCH DI GNS3

Assalamualaikum warrohmatullahiwabarokatuh, 
Setelah beberapa hari gak nulis alhamdulillah sekarang lagi niat-niatnya nulis lagi 🙂 Kali ini ada pembahasan lagi mengenai simulator GNS3. Seperti yang sudah diketahui pada networker sekalian kalau GNS3 sering dipakai sebagai simulator router Cisco, Juniper, Mikrotik dan Virtual Machine. Jarang terlihat GNS3 dipakai untuk simulator Switch tentunya yang manageble seperti switch Cisco. Namun bukan tidak mungkin kalau GNS3 dapat dipakai untuk mengsimulatorkan switch.
Walaupun agak memaksa yaitu dengan menggunakan IOS c3640-is-mz.124-21, namun dengan cara ini kita dapat mengsimulatorkan hampir mirip seperti switch manageble minimal untuk konfigurasi VLAN.
Langkah-langkah untuk membuat switch manageble di GNS3 adalah seperti berikut. Pertama, kita buat simbol terlebih dahulu untuk switch dengan cara klik menu Edit > Symbol Manager.

Cari simbol “ethernet_switch” pada kolom “Available symbol” kemudian klik tanda “>”. Beri nama “switch” dan tambahkan tipenya ke “Router c3600”.

Langkah kedua browse IOS Cisco c3640-is-mz.124-21 dengan cara klik menu Edit > IOS images and hypervisors.
Langkah ketiga tarik switch yang sudah dibuat ke area kerja GNS3. Misalkan kita tarik 2 switch dan ganti hostname Switch1 dan Switch2.
Klik tanda play untuk menyalakan kedua switch dan sebagai contoh konfigurasi buat database vlan pada switch tersebut.

Router>enable 
Router#configure terminal
Router(config)#hostname Switch
Switch(config)#exit
Switch#vlan database 
Switch(vlan)#vlan 10 name “vlan 10”
VLAN 10 added:
    Name: vlan 10
Switch(vlan)#vlan 20 name “vlan 20”
VLAN 20 added:
    Name: vlan 20
Switch(vlan)#vlan 30 name “vlan 30”
VLAN 30 modified:
    Name: vlan 30
Switch(vlan)#exit
APPLY completed.
Selamat mencoba 🙂